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[bookmark: _Toc94175122]Introduction and Background
[bookmark: _Toc436121987][bookmark: _Toc297825328][bookmark: _Toc297892680][bookmark: _Toc298968222][bookmark: _Toc370744760]UPlan is the UCSF customized software of Oracle Enterprise Performance Management (EPM), a budgeting and forecasting application suite that includes Oracle Hyperion Planning.  Hyperion Planning sits on top of Oracle Essbase, a multidimensional database management system (MDBMS) that provides a multidimensional database platform upon which to build analytic applications.    
[bookmark: _Toc436121988][bookmark: _Toc94175123]What is Essbase?
Essbase, whose name derives from “Extended Spread Sheet dataBASE”, began as a product of Arbor Software, which merged with Hyperion Software in 1998.  Hyperion Planning uses Essbase as a database and calculation engine, a relational repository for business logic, and a web-based user interface.  
[bookmark: _Toc94175124]What is Smart View?
Oracle Smart View for Office (Smart View) is a product in the Oracle EPM suite mentioned above that connects with Hyperion Planning and Essbase to allow users to view, import, manipulate, distribute and share data in Microsoft Excel, Word and PowerPoint.   
[bookmark: _Toc94175125]Why use Smart View?
UCSF uses Smart View for three main purposes:
1. An Excel interface for ad hoc analysis and reporting
2. An Excel interface for data input instead of the web-based forms
3. An Excel interface for viewing FR reports 
[bookmark: _Toc94175126]Smart View Add-in 
This document instructs how to download Smart View as an Excel add-in.  It then describes the Smart View Planning Forms, accessed using the Oracle Hyperion Planning, Fusion Edition option below.  Hyperion Planning is used to input data and run form reports in Excel.  Any reference to Smart View in this document should be taken in this context.  The three purposes of Smart View above are explained in relation to the three access options below.

[image: C:\Users\dbeaman\Desktop\2016-01-29_10-01-06.jpg]
[bookmark: _Toc94175127]Oracle Essbase
Oracle Essbase is the underlying database location where the raw data is stored.  This option goes directly to the multidimensional Essbase cubes (databases) for ad hoc analysis and reporting.  Users may create analyses/reports from a blank spreadsheet or refresh from pre-made templates.  
[bookmark: _Toc94175128]Oracle Hyperion Planning, Fusion Edition
The Hyperion Planning, Fusion Edition platform sits on top of the Essbase databases.  This option allows users to access the planning web forms via Excel.  Identical to the web, these forms are for data input or reports.  
[bookmark: _Toc94175129]Reporting and Analysis Framework
Reporting and Analysis Framework is the Excel interface for Hyperion Financial Reports (FR).  In the web interface FR reports are located via the Explore button: [image: C:\Users\dbeaman\Desktop\2016-01-08_13-00-43.jpg].  This option is not covered in any training documentation, although is very similar to the Hyperion Planning Fusion Edition functionality in nature.
[bookmark: _Toc94175130]Getting Started
[bookmark: _Toc442451757][bookmark: _Toc94175131][bookmark: _Toc370744763][bookmark: _Toc298514923]Download and Install Smart View (download using any browser except Internet Explorer)
[bookmark: _Toc94175132]To get started 
1. Confirm you have admin access to your machine.  If you do, skip to Step 2.  If you do not, you will be unable to download Smart View.  To request admin access, put in an ITS ServiceNow INC ticket and give the IT Field Services representative these instructions: 
2. Close all Microsoft products (Internet Explorer, Outlook, Word, Excel, Access, Visio, Project, PowerPoint, Lync, OneNote, Teams, InfoPath, Publisher, etc.)
3. Uninstall all older versions of Smart View from your system before installing the latest version.
[bookmark: _Toc94175133]To uninstall an older version of Smart View
1. Click Start 
2. Select Settings
3. Select System
4. Select Apps & features
5. Select the program you want to uninstall by clicking on it, and then click the Uninstall button
6. Restart your machine
[bookmark: _Toc94175134]To download and install Smart View
1. Download Smart View from any browser except Internet Explorer from the UPlan website at https://brm.ucsf.edu/uplan.
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2. Double-click on the “SmartView” application file.
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3. Click “Extract all” in the dialog box that appears.
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4. Click “Extract” in the dialog box that appears.

[image: ]


5. Within the extracted folder, right-click on the “SmartView” application file and click “Run as administrator.”

[image: ]


6. Click “OK” in the dialog box that appears to proceed with installing Smart View.  Installing may take several minutes depending upon the speed of your computer or network connection.  During the process, you may see several black boxes flashing on the screen.  Do not touch the boxes or attempt to control the installation process.  When the download process is finished, you will see a small dialog box confirming the download is complete.
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7. Open Excel.

8. Go to the File tab > Options > Add-ins.

9. You should see the Oracle Hyperion Smart View add-ins (there should be two) in the Active Application Add-ins section.  If you don’t see the add-ins here, then go to the drop down menu at the bottom of the dialog box and select “Disabled Items.”  You should see the Oracle add-ins in the dialog box that appears now.

[image: ]
10. You should now see a new tab at the top of your Excel workbook titled “Smart View.”  Select the tab to launch Smart View.  If the Smart View tab ever disappears, see the Troubleshooting section to bring it back.
[image: C:\Users\nluong\AppData\Local\Temp\SNAGHTML10404dd7.PNG]

[bookmark: _Toc94175135]Launch Smart View 
[bookmark: _Toc94175136]To Log On to Smart View
1. Launch Microsoft Excel (MS Office 2007 and higher).
2. Select the Smart View tab.
[image: ]

3. In the Smart View Ribbon, select Options icon. This action opens the Options window.
4. Within the Options window, select Advanced in the left pane.  This action opens the Advanced tab of the Options window.

[image: ]

5. In the General section, under Shared Connections URL, input the following URL: https://uplan.ucsf.edu/workspace/SmartViewProviders
[image: ]

6. Click OK.  This action saves the Shared Connection edit.
7. In the Smart View ribbon, navigate to Panel.  This opens the Smart View Panel.
[image: ]

8. In the Smart View pane, click on Shared Connections. This action prompts the Shared Connections log-in pop-up window to appear.


· Shared Connections are available connections from a shared repository where business users can connect to group connections.  This connection is used the majority of the time to leverage Planning templates and Workspace content.
· Private Connections locally define connections and shortcuts.  
· The Home icon lets you navigate between Shared Connections and Private Connections.

9. Enter your UPlan User Name and Password.  Note that this is probably the same as your UCSF Active Directory (AD) ID and password.  Click Connect in the dialog box. This action activates the connection to UPlan via Smart View. 

[image: ]

10. Once the connection is active, click the “Select Server to proceed” drop down window and select the appropriate Hyperion tool:
· Oracle Essbase allows ad-hoc analysis [functionality explained in separate training document]
· Oracle Hyperion Planning, Fusion Edition allows data entry form templates 
· Reporting and Analysis Framework - formatted reports from Financial Reporting (FR) into Excel 
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11. Select the Oracle Essbase option. 
· Click on the + sign to Expand EssbaseCluster-1.  
· Expand the CmmtPln and USFPlan applications.  
· Expand the applications and double-click on the cubes/databases you wish to use.

[image: ]

12. [bookmark: _Toc370744764]Double-click on the Task List to open it.  Or, single-click on the form, and click on the bolded Open form button below the forms.

13. Repeat the same steps to open a form. 

14. To move between General and Employee Task Lists, click General Planning and change it to Employee and vice versa.

15. To move between Gen/Empl to Commitment Task Lists and vice versa click the arrow next to the Home Icon.
[image: ]

16. Click on Shared Connections.



17. Double-click on Commitment Tracking > the Task List changes
[image: commitment_tracking_task_list]

[bookmark: _Toc94175137]Set User Preferences via Options
Setting Smart View options is a user preference.  The following settings are recommended for using the Smart View Planning Forms.  
1. From the Options window, select the Member Options tab and set settings as seen in screenshot below:
[image: ]
· Zoom In Level – used for drilling on any dimension.  Typical user preference is “Next Level.”  This will drill down one level of the hierarchy at a time.
· Member Name Display – choose between displaying Member Name Only, Member Name and Description, or Description Only.
· Indentation – choose whether to indent totals, subtotals, or no indentation for visual purposes.  Note: indentation of Dimension lists indicates the Dimension’s hierarchy.
· Member Retention – Include Selection; this will keep totals when drilling on them.
· Use Double click for Operations – allows mouse functionality for drill-down.  
· Preserve Formula on POV Change – POV (Point of View) box changes will retain Excel formulas. 

2. Select the Data Options tab and set settings as seen in screenshot below: 

· Suppression Options (Rows/Columns) – Choose whether to display blank rows or columns that have no data.  Note:  Having this option checked will improve query times.
· Replacement - This is the text result that appears when query result is zero/no data.
· #NoData/Missing – delete “#Missing” so that it is blank
· #NoAccess Label – #No Access (default); sometimes replaced with “N/A”
· Invalid/Meaningless – #Invalid (default); or #NumericZero
· Mode – screenshot options above are default and generally used.
· Note:  “Navigate Without Data” should only be checked when running large queries to see the metadata or dimension structures without needing to see the data. 

3. Select the Advanced tab and set settings as shown in the screenshot below:

[image: ]

· Shared Connections URL – should have been completed in previous section – “Smart View Setup”.  Ensure it is set to: https://uplan.ucsf.edu/workspace/SmartViewProviders
· Number of Undo Actions – default is 9; similar to MS Office “Undo” feature; handy option if you drill down too far or refresh query and do not want to keep results.
· Logging – this is generally never used.  Creates log files and records errors, events and other information.  This can help IT Customer Support troubleshoot issues.
· Display – screenshot options above are default and generally used. 
· Disable Smart View in Outlook – Smart View can cause conflicts in Excel if Outlook has Smart View enabled simultaneously.  Check this box.
· Compatibility – screenshot options above are default and generally used. 
· Mode – screenshot options above are default and generally used. 


4. Select the Formatting tab and set settings as shown in the screen shot below:

· Formatting
· Use Thousands Separator – enables Excel option for thousands separator (comma or decimal); highly recommended
· Use Cell Styles – ability to change the formatting for data and metadata on the form.  This is the default option for Planning Forms.
· Use Excel Formatting – retains all Excel formatting.  This is an option for Essbase Ad hoc queries.
· Move formatting on operations – retains the Excel formatting such as thousands comma separator and rounding.  This is an option for Essbase Ad hoc queries.  
· Scale – default will display real value in database.  Can change by default to scale to tens, thousands, etc. for report display
· Decimal Places – by default, will generally show complete value in cell (including fractions)
5. Cell Styles and Extension tabs – default options do not need to be change.

[bookmark: _Toc94175138]Set User Preferences via Smart View Panel
Just as with Planning Web, you can choose your display and user variable options in Smart View.  To do this:
1. Click on the Smart View Ribbon > Panel button > Click the down-arrow next to the Home icon > Click on Shared Connections.
2. Right-click on the application you wish to change settings for: UPlan or CommtPlan > User Preferences.  The Display Settings tab allow you to choose how data is displayed.  The User Variable Options tab is where you set your MyOrg DeptID. 


[image: ]

3. Type your MyOrg DeptID in the Selected Member box.  The quick way to do this is to type the number directly into the box.  For example, to set your MyOrg equal to the entire campus you would type D999999.  
4. If you do not know the DeptID: Click on the elipses box […] and the Member Selection dialog box comes up.
[image: ]
5. You have two options:
a. Type the DeptID without the D.  It will find and select the DeptID for you; or
b. If you do not know the DeptID, you can expand the DeptID hierarchy, then expand Total DeptID, expand 999999, keep expanding until you find your DeptID.  For ease of searching, click the Show Aliases box in the bottom left corner of the dialog box.  The DeptID aliases appear along with the DeptID numbers.
[image: ]
6. Once your DeptID is selected, click the right arrow in the middle of the dialog box so that it appears in the right side under “Selected Members”.  Click ok.  Make sure these are set in UCSFPlan and CmmtPlan.

[bookmark: _Toc94175139]Dimensions in Smart View
Dimensions are metadata within a dimensional database and are the primary way that data is categorized in UPlan.  Members are the individual representations for the dimensions.  For example, Period is a dimension that has “Jul” and “Aug” as members.  You will notice differences between the Dimensions that you can view in the UPlan web interface versus UPlan in Smart View.  Some of these key differences are described below.
[bookmark: _Toc94175140]Period
The Period dimension contains “YearTotal” and months.  There is an additional member called Admin_Period that is hidden in web forms.  This member should not be used for retrievals as it has no data associated with it.
[bookmark: _Toc94175141]Years
The Years dimension contains members for years not currently included on the General Planning and Employee Planning forms (i.e. 2023-24, 2024-25).  In General Planning and Employee Planning, there is no data associated with the outlying years so they should not be used.

[bookmark: _Toc94175142]Scenario
The Scenario dimension is the same in the planning forms as it is in ad hoc reporting.
[bookmark: _Toc94175143]Version
The Version dimension contains a “What If” member that is hidden in the web forms.  This member should not be used for retrievals as it currently contains no data.
[bookmark: _Toc94175144]Fund
The Fund dimension contains an additional group of members under a hierarchy called “Global Assumptions Funds.”  These members assist with the Global Assumption process and have no data associated with them so they should not be used.
[bookmark: _Toc94175145]DeptID
The DeptID dimension contains an additional group of members under a hierarchy called “Input DeptID.”  These members assist with the Global Assumption process and have no data associated with them so they should not be used.
[bookmark: _Toc94175146]Title Code
The Title Code dimension contains job codes assigned to individual employees.  An employee can have multiple job codes.  Job Codes are organized in several hierarchies, including by Union Code.  To look up a Job Code and its Union Code, refer to the Job Code lookup in MyReports (Inquiry Reports Tab), the Controller’s Office website (Inquiry Reports Tab), or the HR website.  Smart View users should use the “All Title_Codes” or “Employee Type” hierarchies for data retrievals.  The Input hierarchy is only used to facilitate Global Assumptions processes and contains no data.
[bookmark: _Toc94175147]Project
The Project dimension is set up exactly as it is in web forms.  The hierarchy includes the Project Use as well as individual Project IDs.
[bookmark: _Toc94175148]Account
The Account dimension is essentially the same in Smart View as the web except all accounts are included within this dimension in two separate hierarchies—one hierarchy is for Employee accounts and the other is for General Planning accounts.  For a full Account listing you can right-click on any account in any form > hover over Smart View > click Add Account > a dialog box called Member Selection appears > click the magnifying glass button at the bottom > the list of available accounts shows up > click the Show Aliases box in the lower left corner > Add relevant Account.

[bookmark: _Toc94175149]Navigating with the Smart View Ribbon
The Smart View ribbon acts as the hub for connecting to applications.  It appears upon opening Excel and will stay open regardless if you are connected or not.  All relevant buttons are outlined below.



	Item
	Description

	Panel
	Used to connect and disconnect to and from UPlan servers and databases.

	Connections
	This button is not used.

	Undo/Redo
	Undo/redo the previous ad hoc operation.  Once data is submitted, these buttons do not work.

	Copy/Paste Data Point
	Just like Excel, however will not paste values a second time.

	Functions
	Not currently using these options.

	Refresh
	Refresh the data and metadata on the current worksheet from the data source. 

	Submit Data
	Submits data back to the Planning database.  Be careful, there is no Undo.  This button only works at planning-level intersections. 

	Options
	Allows user to set a variety of preferences for working in Smart View.

	Sheet Info
	Display whether the sheet has an active connection and if so, to which server, application and database.

	More
	Not currently using these options.



[bookmark: _Toc94175150]Planning Forms in Smart View
[bookmark: _Toc94175151]Accessing Planning Forms via Smart View
1. Planning Forms via Excel are available using Hyperion Planning Fusion Edition.  Go to Shared Connections and select the Oracle Hyperion Planning, Fusion Edition server in the drop down menu.

2. All of the databases for UPlan will appear.  
[image: ]
3. Expand the server uplan.ucsf.edu.
4. Expand the Task Lists folder under each application.
5. Double-click on the Task List, or single-click on the Task List then single-click on Open Task List.  Repeat these steps to open Forms. 
6. The form opens and the Planning tab appears.  
7. Note: you can select regular data entry forms, landing pages, and form reports.  From landing pages, you can navigate to data entry forms.  Data can only be submitted via a data entry form.  To navigate back from a form to a task list click the down arrow next to the Home icon and choose the Task List you wish to see.

[bookmark: _Toc94175152]Navigating with the Planning Ribbon
The Planning tab becomes active when the worksheet becomes connected to a planning database.  It shows the specific options for planning on the data entry forms.  All relevant buttons are outlined below.  The most commonly used buttons are also located on the Smart View tab such as Refresh and Submit Data.


	Item
	Description

	Analyze
	Creates a new tab for ad hoc analysis.  This button is not used.

	Refresh
	Erase any un-submitted data and refresh with data and metadata from the UPlan database.

	POV
	Make the POV drop down menus visible or not visible.

	Cell Actions
	Insert Comment, Supporting Detail, Attachment or view Cell History for this intersection.  None of these are viewable in Form Reports or Financial Reports (FR).

	Lock
	Lock the cell you wish to remain unchanged.  Cell unlocks itself upon refresh or submit.

	Calculate
	There is no reason to use these.  All relevant business rules should be run via the right-click menu options.

	Adjust
	Adjust a cell by a certain value up or down, multiplier, divider, or percentage up or down.

	Grid Spread
	Adjust a cell and its spread pattern across periods if not proportional (default).

	Drill Through
	Not currently activated.

	Submit Data
	Sends data to the UPlan database.

	Approvals
	Not currently activated.

	Copy Version
	Copy Draft Version into Forecast or vice versa.


   
[bookmark: _Toc94175153]Using Planning Forms in Excel
Everything you can do in the web forms you can do in Excel.  In fact, Excel allows for even greater functionality because you can use normal Excel features such as Freezing window panes, cell references, and formulas.
[bookmark: _Toc94175154]Navigating Forms in Smart View
The forms you access via Smart View will look and feel very similar, but not identical, to the web forms.
· Cell Shading:  In Smart View, cell colors are somewhat different.  Writable cells are light yellow instead of white.  Unsaved cells are dark yellow.
· Expand/Collapse:  To drill down or expand a dimension, double-click on members with a + sign, such as YearTotal; double-right click to collapse/zoom-out, such as Months.  
· Point of View:  To retrieve data for another intersection, use the drop-down menus in the POV at the top of the form and hit the refresh button.  Note the POV is not a Hyperion Smart List so the drop down menus use “type-ahead” and Excel Tab and Enter functionality.  The retrieval speed is markedly faster than the web forms.
· Composite Forms:  Composite forms will appear as multiple tabs when accessed via Smart View.  For example, the Edit Commitment form will appear as two separate worksheets – one for Commitments Attributes and one for Commitments Dollars.  Note that the Excel interface will only allow you to work in one composite form at a time per application per workbook.  For example in CommtPlan this means right-clicking to Edit Existing Commitment from the Manage Commitment Form open a new workbook with two new worksheets (one tab for each tab in the composite form).  Commitment Attributes is the first tab and Commitment Dollars is the second.  However if you navigate back to the Manage Commitment tab, or open a second Manage Commitment tab, right-clicking on a different Commitment number, then choosing Edit Existing Commitment, Smart View will always populate the second workbook with the most recent Commitment you are trying to edit.


[bookmark: _Toc94175155]Updating Forms
Planning in Excel works exactly like the web form with a few differences.
1. Entering Data:  As with web forms, you can enter data in any writable cell simply by clicking on the cell and entering a value.
2. Right-click Menus:  In Smart View, right-click menus work similarly to those in the web forms, although options are found by right-clicking on the Account > click on/hover over “Smart View” > select the appropriate option.
3. Copy and Paste:  By using the right-click menus, using Ctrl+C and Ctrl+V, or using the icons on the Planning ribbon, you can copy and paste values from one cell to another.  However, if you try to Copy/Paste by clicking Ctr+C and Ctrl+V within the form twice, it will not paste the values a second time.
4. Adjust Data and Grid Spread:  These options for updating data work similarly in Smart View and can be accessed via right-clicking or using the icons in the Planning ribbon.
5. Add/Remove Rows:  As in web forms, add or remove rows or by right-clicking on the account and selecting Smart View > Add/Remove Account/Commitment/Distribution.
6. Navigating from Landing Pages:  If you use a right-click menu on a landing page to access another form, the new form will appear in a new Excel worksheet.  For example, if you choose Edit Existing Commitment from the right-click menu of the Commitments landing page, a new Excel worksheet will appear containing the commitment data entry forms.
[bookmark: _Toc94175156]Using Excel Features
· Move from cell to cell using your keyboard arrows.
· Enter data in white cells outside the boundaries of the data entry form.
· Reference other cells (e.g., “=B5”).
· Calculate values (e.g., “=10*B5).
· Hide/unhide rows or columns just like in Excel.
· Freeze panes just like in Excel.
· You may add as many tabs you wish to your Excel worksheet.

[bookmark: _Toc94175157]#Missing
· #Missing = no data in that cell/intersection.
· You can enter data in a cell that says #Missing as long as it is a writable intersection.
· You can eliminate data in a cell by entering #Missing instead.
· You can use the Options menu to change #Missing to a Blank cell or NumericZero by going to your Smart View ribbon> Options button > Data Options > Replacement section.
· NOTE: #Missing ≠ Zero.  Zero is a data value whereas #Missing is the absence of data.

[bookmark: _Toc94175158]Refresh Buttons
Typically, there will be two Refresh options when accessing forms via Smart View.
· The Refresh button in the POV (next to the drop down menus) is the Go button in web forms.  Selecting this Refresh button refreshes the form for the POV combination selected, just like on web forms.  You must click the Refresh button to update the POV for the form.
[image: C:\Users\dbeaman\Desktop\2016-01-25_10-27-38.jpg]
· The Refresh button on the Smart View and Planning ribbons include two options:
[image: C:\Users\dbeaman\Desktop\2016-01-25_10-29-44.jpg]
[image: C:\Users\dbeaman\Desktop\2016-01-25_10-28-34.jpg]
a. Refresh erases any unsaved data on the form and retrieves the most current data and metadata from the UPlan database.  This button does not erase formulas.  
b. Refresh All Worksheets erases any unsaved data on the form and retrieves the most current data from the UPlan database for all worksheets. This button does not erase formulas.  
· No Refresh button options will erase your formulas.
· Smart View Panel > Double-clicking Form or Open Form > WILL erase your formulas.  This pulls the form and data from the database (where no formulas exist).  If you need to re-open the Form this way, Copy the Worksheet then Paste the data [including formulas] into the re-opened worksheet.
[image: ]
[bookmark: _Toc94175159]Using Multiple Tabs
From within a single Excel workbook, users can use multiple worksheet tabs to connect to forms more than once for different POV combinations or connect to multiple forms.  
· To connect to an additional form from within a workbook, simply navigate to a new Excel worksheet and repeat the connection steps described earlier.
· You may connect as many tabs to UPlan as you wish (Planning or Essbase), however performance tends to decrease with more than a few connections.  Excel may become unresponsive or crash.  In this case, go to your panel, click Disconnect All (screenshot below) > Reconnect to only one or two necessary worksheets at any time.  If this does not work, try saving your Excel.xlsx file, closing, opening file, connect to only the worksheets you wish to submit data in.



· When opening an Excel file with multiple worksheets with previous connections, using Ctrl + selecting only the worksheets you wish to connect.  This will selectively connect the worksheets to the databases you had previously connected to.
[image: C:\Users\dbeaman\Desktop\2014-10-27_9-56-16.jpg]

· Closing Excel will automatically disconnect from any and all active connections.
· Opening Forms options are identical to Planning Web.  If a Form is Open and Connected in Smart View and you want to navigate to another form simultaneously you have two options:
a. Option 1: From current open form, navigate to Smart View Panel > double-click on a different form or click Open Form.  However just like Planning Web, this option erases any unsaved data, AND since it is Excel will erase any formulas you had on the current form.
[image: preserve_formula_data_options]
b. Option 2: From current open form, navigate to a new blank Excel worksheet, Smart View Panel > Connect to database > Open different Form.  This preserves the formulas and unsaved data in other open forms.
[bookmark: _Toc94175160]Save versus Submit versus Open Form in Smart View
While using Smart View, you can save your Excel file to your desktop or shared drive, and you submit data to UPlan.  These are distinct, separate actions.  
· In the web form, Save [image: C:\Users\dbeaman\Desktop\2016-01-25_10-35-35.jpg] pushes data to the database and updates the form.  

· In Smart View, Submit Data pushes data to the database and updates the form.  

[image: C:\Users\dbeaman\Desktop\2016-01-25_10-36-47.jpg]
Submit Data buttons appear in both the Smart View and Planning ribbons.  (Although the icons look different the functionality is the same.) 
· Just like planning web, Submit Data will send all unsaved data in a composite form back to the database.
· Submit Data for multiple active worksheets at the same time by selecting the worksheets using Ctrl + select worksheets > Submit Data on any active worksheet.
· Once data is submitted to the UPlan database the Undo feature will no longer work.
· In Smart View, Excel > File > Save/Save As saves a local Excel.xlsx version of your document.  It does not Save or Submit anything back to the database.  If you save data in your workbook on your local desktop without having submitted changes to the UPlan database, you can return later and still submit the data, as long has you have not clicked on the Refresh button in the Planning ribbon.
The following table can be used when trying to remember the differences between Submit, Save and Open Form.

	Action
	What it does
	
	
	
	Risks
	When to use

	Ctrl+S (Save)
	Saves a version of your form to your computer
	Does not send data to the UPlan database
	Only use if you have formulas, cell references or supplemental data in your workbook; if you do save your workbook locally, always use it to make further changes to your plan/forecast

	Refresh
	Refreshes the data on your form with current data from the database for the POV selected
	Does not save or submit any changes you made (except formulas are retained)
	If you have made a mistake that has not yet been submitted to UPlan and want to start over

	Submit Data
	Sends data to the UPlan database
	Does not save data locally; cannot Undo after you Submit Data
	Often – while you don’t need to submit data every time you make a change, submitting frequently ensures you don’t lose your work

	Open Form
	Re-opens your form with current data from the UPlan database for the POV selected
	Does not save or submit any changes you make (including formulas)
	Only as a last resort



[bookmark: _Toc94175161]Troubleshooting 
[bookmark: _Toc94175162]If Smart View is disabled
1. Open Excel and go to File > Options > Add-Ins.
2. On the Manage drop down list at the bottom of the Options window, select “Disabled Items” and click Go. 


3. After you click on Go the following window will appear.
	[image: disabled_items_window] 

4. In the case where Smart View was disabled, you will see Smart View in the disabled items box.
5. Select Smart View and click on Enable.
6. Close Excel.
7. Re-open Excel.  Smart View should show up again.  
8. If it does not, Open Excel and go to File > Options > Add-Ins. On the Manage drop down list at the bottom of the Options window, select “COM Add-ins” and click Go. 
9. After you click Go the following window will appear.



10. In the case where Smart View is not checked, check the box.
11. Close Excel.  Re-open Excel.  Smart View should show up again.
[bookmark: _Toc94175163]UPlan User Support Info
For user support on Smart View, contact uplan@ucsf.edu.
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